USB laufwerke

Biotop für Pinguine
Antworten
Benutzeravatar
Brill
Nutzer
Nutzer
Beiträge: 835
Registriert: 13.02.2006, 18:51
Wohnort: Bobingen

USB laufwerke

Beitrag von Brill » 04.04.2007, 21:15

der pc erkennt zwar das ein Usb laufwerk da ist, aber nach dem manuellen mounten kann ich nicht darufschreiben.
(\_/)
(x.x)
(> <)
This is Bunny.

Bunny is dead please use another Bunny for copy and use it for the world Domination.

Benutzeravatar
_Micha_
Der Bi-Ba-Butzelmann
Beiträge: 2001
Registriert: 10.02.2006, 00:09
Wohnort: Kelsterbach
Kontaktdaten:

Beitrag von _Micha_ » 04.04.2007, 21:21

Wenn du manuell mountest, solltest du in der /etc/fstab bei den options (also bei "user, auto,..." auch ein rw mit dranhängen bzw. das 'r' durch ein 'rw' ersetzen.

Ansonsten: was ist mit automount, wenn du das USB-Gerät anstöpselst?
TRUST IN ALUMINUM! SAVE THE PLASTIC FOR DILDOS

Benutzeravatar
Brill
Nutzer
Nutzer
Beiträge: 835
Registriert: 13.02.2006, 18:51
Wohnort: Bobingen

Beitrag von Brill » 04.04.2007, 21:28

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 / ext3 defaults,errors=remount-ro 0 1
/dev/sda5 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

so sieht sie aus. ich glaub auto mount geht nciht
(\_/)
(x.x)
(> <)
This is Bunny.

Bunny is dead please use another Bunny for copy and use it for the world Domination.

Benutzeravatar
_Micha_
Der Bi-Ba-Butzelmann
Beiträge: 2001
Registriert: 10.02.2006, 00:09
Wohnort: Kelsterbach
Kontaktdaten:

Beitrag von _Micha_ » 04.04.2007, 21:31

Hm... da steht kein USB-Laufwerk drin. Das wird glaube ich bei ubuntu mittels udev dynamisch eingebunden. Du könntest das USB-Gerät mal dranstecken und dann mit "df -h" die Geräte anzeigen lassen. Wenn das USB-Gerät angezeigt wird, kannst du ne Zeile in der fstab hinzufügen.
TRUST IN ALUMINUM! SAVE THE PLASTIC FOR DILDOS

Benutzeravatar
_Micha_
Der Bi-Ba-Butzelmann
Beiträge: 2001
Registriert: 10.02.2006, 00:09
Wohnort: Kelsterbach
Kontaktdaten:

Beitrag von _Micha_ » 04.04.2007, 21:34

Ach ja, welches Dateisystem ist auf dem USB-Datenträger? Ist das ein Stick mit vfat oder ne Platte mit NTFS. Hattest du mir zwar schonmal irgendwann per Mail geschrieben, aber ich weiß es nicht mehr.


Evtl. solltest du mal prüfen, ob du auf dem Mountpunkt Schreibrechte hast. Dazu "ls -l", falls es im $home liegt. Ansonsten musst du beim Wurzelverzeichnis beginnen und schauen, dass du aufsteigend im Baum bis zum Ziel ausreichende Schreibrechte besitzt.
TRUST IN ALUMINUM! SAVE THE PLASTIC FOR DILDOS

Benutzeravatar
Brill
Nutzer
Nutzer
Beiträge: 835
Registriert: 13.02.2006, 18:51
Wohnort: Bobingen

Beitrag von Brill » 04.04.2007, 21:43

ls -l gibt folgendes aus (hab ein paar datei namen weggemacht)
sebastian@Nucleon:~$ ls -l
insgesamt 520
-rw-r--r-- 1 sebastian sebastian 12212 2007-03-30 17:29
-rw-r--r-- 1 sebastian sebastian 242212 2007-03-30 17:34
drwxr-xr-x 3 sebastian sebastian 4096 2007-03-25 17:09 Bilder
drwxr-xr-x 3 sebastian sebastian 4096 2007-04-02 22:58 C
drwx------ 2 sebastian sebastian 4096 2007-04-03 09:39 Desktop
drwxr-xr-x 2 sebastian sebastian 4096 2007-04-04 21:10 Dokumente
drwxr-xr-x 2 sebastian sebastian 4096 2007-04-03 18:36 Downloads
drwxr-xr-x 19 sebastian sebastian 4096 2007-04-02 23:01 Eigene Musik
-rw-r--r-- 1 sebastian sebastian 21198 2007-03-30 21:34
-rw-r--r-- 1 sebastian sebastian 130055 2007-03-27 00:04
-rw-rw-r-- 1 sebastian sebastian 24362 2007-04-03 00:19
-rw-rw-r-- 1 sebastian sebastian 10269 2006-10-02 21:50
drwxr-xr-x 2 sebastian sebastian 4096 2007-04-04 21:10
-rw-r--r-- 1 sebastian sebastian 17327 2007-04-01 11:10
-rw-r--r-- 1 sebastian sebastian 7173 2007-04-01 11:12
-rw-r--r-- 1 sebastian sebastian 12695 2007-03-27 00:14
sebastian@Nucleon:~$


sebastian@Nucleon:~$ df -h
Dateisystem Größe Benut Verf Ben% Eingehängt auf
/dev/sda1 89G 4,3G 81G 6% /
varrun 506M 96K 506M 1% /var/run
varlock 506M 4,0K 506M 1% /var/lock
udev 506M 120K 506M 1% /dev
devshm 506M 0 506M 0% /dev/shm
lrm 506M 19M 487M 4% /lib/modules/2.6.15-28-386/volatile
/dev/hda 2,2M 2,2M 0 100% /media/cdrom0
/dev/sdb1 484M 28M 456M 6% /media/sdb1
sebastian@Nucleon:~$


hier wird das usb laufwerk erkannt

gib es ein programm, welches automatisch beim anstecken des usbsticks einen ordner kopiert? bzw ist das dann doch ein script oder?
(\_/)
(x.x)
(> <)
This is Bunny.

Bunny is dead please use another Bunny for copy and use it for the world Domination.

Benutzeravatar
_Micha_
Der Bi-Ba-Butzelmann
Beiträge: 2001
Registriert: 10.02.2006, 00:09
Wohnort: Kelsterbach
Kontaktdaten:

Beitrag von _Micha_ » 04.04.2007, 21:48

Du könntest so vorgehen:

- im Homeverzeichnis einen Ordner anlegen, bspw. "usbstick"
- dann folgende Zeile in die fstab:

Code: Alles auswählen

/dev/sdb1   /home/sebastian/usbstick  vfat    rw, users, auto       0       0


- mounten dann mit "mount -a" oder "mount usbstick"


- für automatisches kopieren wäre ein Skript angebrach. Aber da der Inhalt des Sticks dann eh verfügbar ist, kannst du das auch so mit dem Dateibrowser machen.
TRUST IN ALUMINUM! SAVE THE PLASTIC FOR DILDOS

Benutzeravatar
Brill
Nutzer
Nutzer
Beiträge: 835
Registriert: 13.02.2006, 18:51
Wohnort: Bobingen

Beitrag von Brill » 04.04.2007, 22:16

sebastian@Nucleon:~$ sudo mount a-
[mntent]: warning: no final newline at the end of /etc/fstab
[mntent]: line 8 in /etc/fstab is bad
mount: can't find a- in /etc/fstab or /etc/mtab
sebastian@Nucleon:~$


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 / ext3 defaults,errors=remount-ro 0 1
/dev/sda5 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sdb1 /home/sebastian/usbstick vfat rw, users, auto 0 0


fehlt da noch was?
(\_/)
(x.x)
(> <)
This is Bunny.

Bunny is dead please use another Bunny for copy and use it for the world Domination.

Benutzeravatar
_Micha_
Der Bi-Ba-Butzelmann
Beiträge: 2001
Registriert: 10.02.2006, 00:09
Wohnort: Kelsterbach
Kontaktdaten:

Beitrag von _Micha_ » 04.04.2007, 22:54

Die letzte Zeile in der fstab soll leer sein, sprich in der letzten Zeile sollen keine Argumente mehr stehen. Ansonsten OK.
TRUST IN ALUMINUM! SAVE THE PLASTIC FOR DILDOS

Benutzeravatar
Brill
Nutzer
Nutzer
Beiträge: 835
Registriert: 13.02.2006, 18:51
Wohnort: Bobingen

Beitrag von Brill » 04.04.2007, 23:17

sebastian@Nucleon:~$ mount -a
mount: only root can do that
sebastian@Nucleon:~$ sudo mount -a
Password:
[mntent]: line 8 in /etc/fstab is bad
sebastian@Nucleon:~$

*grübel*
(\_/)
(x.x)
(> <)
This is Bunny.

Bunny is dead please use another Bunny for copy and use it for the world Domination.

Benutzeravatar
_Micha_
Der Bi-Ba-Butzelmann
Beiträge: 2001
Registriert: 10.02.2006, 00:09
Wohnort: Kelsterbach
Kontaktdaten:

Beitrag von _Micha_ » 05.04.2007, 00:47

Keine Leerzeichen hinter den Kommas... musst mal schauen, dass die Daten in etwa so aussehen, wie der Rest in der Datei.
TRUST IN ALUMINUM! SAVE THE PLASTIC FOR DILDOS

Antworten